CCNA - V2 P4 - Managing Cisco IOS Devices
Chia sẻ bởi Nguyễn Duy Diệu |
Ngày 29/04/2019 |
91
Chia sẻ tài liệu: CCNA - V2 P4 - Managing Cisco IOS Devices thuộc Bài giảng khác
Nội dung tài liệu:
© 2002, Cisco Systems, Inc. All rights reserved.
© 2002, Cisco Systems, Inc. All rights reserved.
2
Managing Cisco IOS Devices
Objectives
Upon completing this lesson, you will be
able to:
Manage IOS image files to maintain accessible IOS images according to best practices, given operational access layer switches, routers, and a TFTP server
Manage device configuration files to reduce device downtime according to best practices, given operational access layer switches, routers, and a TFTP server
Execute an add, move, or change on a router, given a new network requirement
Handle the troubleshooting process to minimize any potentially adverse impact on Cisco devices
Cisco IOS File System and Devices
Managing Cisco IOS Images
wg_ro_a#show flash
System flash directory:
File Length Name/status
1 10084696 c2500-js-l_120-3.bin
[10084760 bytes used, 6692456 available, 16777216 total]
16384K bytes of processor board System flash (Read ONLY)
Verify that flash memory has room for the
Cisco IOS image.
Verifying Memory and Deciphering Image Filenames
Back up current files prior to updating flash memory.
Creating a Software Image Backup
Upgrading the Image from the Network
Device Configuration Files
Cisco IOS copy Command
NVRAM
Terminal
TFTP server
Erase start
Cisco IOS copy
Command Example
interface s0
ip address 10.1.1.1 255.255.255.0
interface e0
ip address 10.2.2.2 255.255.255.0
interface e1
no ip address
interface e0
ip address 172.16.1.1 255.255.255.0
interface e1
ip address 192.168.1.1 255.255.255.0
interface s0
ip address 10.1.1.1 255.255.255.0
interface e0
ip address 172.16.1.1 255.255.255.0
interface e1
ip address 192.168.1.1 255.255.255.0
running-config
TFTP Server saved.cfg
Resulting
running-config
copy tftp run (merged)
copy run tftp and
copy tftp run Commands
wg_ro_a#copy running-config tftp
Address or name of remote host []? 10.1.1.1
Destination filename [running-config]? wgroa.cfg
.!!
1684 bytes copied in 13.300 secs (129 bytes/sec)
wg_ro_a#copy tftp running-config
Address or name of remote host []? 10.1.1.1
Source filename []? wgroa.cfg
Destination filename [running-config]?
Accessing tftp://10.1.1.1/wgroa.cfg...
Loading wgroa.cfg from 10.1.1.1 (via Ethernet0): !
[OK - 1684/3072 bytes]
1684 bytes copied in 17.692 secs (99 bytes/sec)
Adding New Devices to the Network
Determine the IP address to be used for management purposes.
Configure administrative access for the console, auxiliary, and vty interfaces.
Configure passwords for the privileged EXEC mode for the device.
Configure the network management access to the device.
Determine the IP address to assign to each interface.
Configure the new device with the appropriate configuration.
Moving Devices on the Network
Determine what to do with the obsolete equipment.
Which devices connect to the equipment being moved?
Will the move and reconfiguration affect the security policy?
Does the device play a role that no other devices play?
Review the facilities for the new location.
After the move, test network connectivity.
Changing the Hardware
Hardware changes
Power down the equipment or use OIR.
Make sure the appropriate modules are available.
Read the hardware installation manual.
Verify your organization’s policies.
Cisco IOS software changes
Does the new version support the current and future features you need?
Does your platform have sufficient RAM and flash memory to support the feature set?
show and debug Commands
Processing characteristic
Processing load
Primary use
show
Static
Low overhead
Gather facts
debug
Dynamic
High overhead
Observe processes
Considerations When Using debug Commands
May generate output in a variety of formats that may not identify the problem
Require high overhead, possibly disrupting network device operation
Useful for obtaining information about network traffic and router status
Commands Related to debug
Router(config)#service timestamps debug datetime msec
Router#show processes
CPU utilization for five seconds: 0%/0%; one minute: 0%; five minutes: 0%
PID Q Ty PC Runtime(ms) Invoked uSecs Stacks TTY Process
1 C sp 602F3AF0 0 1627 0 2600/3000 0 Load Meter
2 L we 60C5BE00 4 136 29 5572/6000 0 CEF Scanner
3 L st 602D90F8 1676 837 2002 5740/6000 0 Check heaps
4 C we 602D08F8 0 1 0 5568/6000 0 Chunk Manager
5 C we 602DF0E8 0 1 0 5592/6000 0 Pool Manager
6 M st 60251E38 0 2 0 5560/6000 0 Timers
Router#no debug all
Summary
The Cisco IOS File System feature provides a single interface to all the file systems that a router uses.
As your network grows, you may want to store
your Cisco IOS software and configuration files on a central server, which would allow you to control the number and revision level of software images and configuration files you must maintain.
Device configuration files contain a set of
user-configured commands that customize the functionality of your Cisco device.
Summary (Cont.)
You use the Cisco IOS software copy commands to move configurations from one component or device to another, such as RAM, NVRAM, or a file server.
Network equipment is often moved from one location to another, removed from the network, or the configuration may change. The process is referred to as adds, moves, and changes.
The show and debug commands are built-in tools for troubleshooting. The show command is used to display static information, while the debug command is used to display dynamic data.
© 2002, Cisco Systems, Inc. All rights reserved.
2
Managing Cisco IOS Devices
Objectives
Upon completing this lesson, you will be
able to:
Manage IOS image files to maintain accessible IOS images according to best practices, given operational access layer switches, routers, and a TFTP server
Manage device configuration files to reduce device downtime according to best practices, given operational access layer switches, routers, and a TFTP server
Execute an add, move, or change on a router, given a new network requirement
Handle the troubleshooting process to minimize any potentially adverse impact on Cisco devices
Cisco IOS File System and Devices
Managing Cisco IOS Images
wg_ro_a#show flash
System flash directory:
File Length Name/status
1 10084696 c2500-js-l_120-3.bin
[10084760 bytes used, 6692456 available, 16777216 total]
16384K bytes of processor board System flash (Read ONLY)
Verify that flash memory has room for the
Cisco IOS image.
Verifying Memory and Deciphering Image Filenames
Back up current files prior to updating flash memory.
Creating a Software Image Backup
Upgrading the Image from the Network
Device Configuration Files
Cisco IOS copy Command
NVRAM
Terminal
TFTP server
Erase start
Cisco IOS copy
Command Example
interface s0
ip address 10.1.1.1 255.255.255.0
interface e0
ip address 10.2.2.2 255.255.255.0
interface e1
no ip address
interface e0
ip address 172.16.1.1 255.255.255.0
interface e1
ip address 192.168.1.1 255.255.255.0
interface s0
ip address 10.1.1.1 255.255.255.0
interface e0
ip address 172.16.1.1 255.255.255.0
interface e1
ip address 192.168.1.1 255.255.255.0
running-config
TFTP Server saved.cfg
Resulting
running-config
copy tftp run (merged)
copy run tftp and
copy tftp run Commands
wg_ro_a#copy running-config tftp
Address or name of remote host []? 10.1.1.1
Destination filename [running-config]? wgroa.cfg
.!!
1684 bytes copied in 13.300 secs (129 bytes/sec)
wg_ro_a#copy tftp running-config
Address or name of remote host []? 10.1.1.1
Source filename []? wgroa.cfg
Destination filename [running-config]?
Accessing tftp://10.1.1.1/wgroa.cfg...
Loading wgroa.cfg from 10.1.1.1 (via Ethernet0): !
[OK - 1684/3072 bytes]
1684 bytes copied in 17.692 secs (99 bytes/sec)
Adding New Devices to the Network
Determine the IP address to be used for management purposes.
Configure administrative access for the console, auxiliary, and vty interfaces.
Configure passwords for the privileged EXEC mode for the device.
Configure the network management access to the device.
Determine the IP address to assign to each interface.
Configure the new device with the appropriate configuration.
Moving Devices on the Network
Determine what to do with the obsolete equipment.
Which devices connect to the equipment being moved?
Will the move and reconfiguration affect the security policy?
Does the device play a role that no other devices play?
Review the facilities for the new location.
After the move, test network connectivity.
Changing the Hardware
Hardware changes
Power down the equipment or use OIR.
Make sure the appropriate modules are available.
Read the hardware installation manual.
Verify your organization’s policies.
Cisco IOS software changes
Does the new version support the current and future features you need?
Does your platform have sufficient RAM and flash memory to support the feature set?
show and debug Commands
Processing characteristic
Processing load
Primary use
show
Static
Low overhead
Gather facts
debug
Dynamic
High overhead
Observe processes
Considerations When Using debug Commands
May generate output in a variety of formats that may not identify the problem
Require high overhead, possibly disrupting network device operation
Useful for obtaining information about network traffic and router status
Commands Related to debug
Router(config)#service timestamps debug datetime msec
Router#show processes
CPU utilization for five seconds: 0%/0%; one minute: 0%; five minutes: 0%
PID Q Ty PC Runtime(ms) Invoked uSecs Stacks TTY Process
1 C sp 602F3AF0 0 1627 0 2600/3000 0 Load Meter
2 L we 60C5BE00 4 136 29 5572/6000 0 CEF Scanner
3 L st 602D90F8 1676 837 2002 5740/6000 0 Check heaps
4 C we 602D08F8 0 1 0 5568/6000 0 Chunk Manager
5 C we 602DF0E8 0 1 0 5592/6000 0 Pool Manager
6 M st 60251E38 0 2 0 5560/6000 0 Timers
Router#no debug all
Summary
The Cisco IOS File System feature provides a single interface to all the file systems that a router uses.
As your network grows, you may want to store
your Cisco IOS software and configuration files on a central server, which would allow you to control the number and revision level of software images and configuration files you must maintain.
Device configuration files contain a set of
user-configured commands that customize the functionality of your Cisco device.
Summary (Cont.)
You use the Cisco IOS software copy commands to move configurations from one component or device to another, such as RAM, NVRAM, or a file server.
Network equipment is often moved from one location to another, removed from the network, or the configuration may change. The process is referred to as adds, moves, and changes.
The show and debug commands are built-in tools for troubleshooting. The show command is used to display static information, while the debug command is used to display dynamic data.
* Một số tài liệu cũ có thể bị lỗi font khi hiển thị do dùng bộ mã không phải Unikey ...
Người chia sẻ: Nguyễn Duy Diệu
Dung lượng: |
Lượt tài: 4
Loại file:
Nguồn : Chưa rõ
(Tài liệu chưa được thẩm định)